Cloudflare System Status

DNS record updates delayed

Incident Report for Cloudflare

Resolved

All recent DNS record updates are now live. We do not expect any further delays.
Posted Apr 22, 2015 - 17:39 UTC

Investigating

We are currently investigating. Stayed tuned for updates.
Posted Apr 22, 2015 - 16:37 UTC