Cloudflare System Status

1.1.1.1 Resolver Issues in Frankfurt, DE
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Mar 04, 2020 - 01:02 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted Mar 03, 2020 - 20:41 UTC
Investigating
Cloudflare is investigating issues with 1.1.1.1 public resolver performance in Frankfurt, DE datacenter.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Mar 03, 2020 - 20:37 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Recursive DNS).