Cloudflare System Status

Cloudflare Dashboard and Cloudflare API service issues

Incident Report for Cloudflare

Resolved

Impacted APIs and the Cloudflare dashboard have fully recovered.
Posted May 22, 2026 - 16:33 UTC

Update

We have rolled back the affected service and are seeing impacted APIs and our dashboard begin to recover.
We expect recovery to be gradual as in-memory caches (not our CDN caches) associated with this service repopulate.
We will provide another update once error rates return to normal, nominal levels.
Posted May 22, 2026 - 16:22 UTC

Monitoring

We are working to safely roll back the affected service underpinning our API entitlements system. We expect recovery to be gradual as in-memory caches (not our CDN caches) associated with this service repopulate.
Posted May 22, 2026 - 16:19 UTC

Update

We are continuing efforts to restore our APIs and the Cloudflare dashboard after identifying an issue with our entitlements service.
Posted May 22, 2026 - 16:05 UTC

Update

We are continuing efforts to restore our APIs and the Cloudflare dashboard after identifying an issue with our entitlements service.
Posted May 22, 2026 - 16:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2026 - 15:41 UTC

Investigating

Cloudflare is investigating issues with Cloudflare Dashboard and related APIs.

These issues do not affect the serving of traffic via our CDN, security features or compute & storage services already deployed.

Creation of new services or modification of existing services are impacted.

Customers using the Dashboard and Cloudflare APIs are impacted as requests might fail and/or errors may be displayed.
Posted May 22, 2026 - 15:36 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).