Minor ImpactLast updated: Refreshed just now
Support Helpdesk Availability Issues
Started
Timeline
- Identified
Support portal and live chat support are still unavailable due to the ongoing helpdesk provider outage. Customers may still experience issues submitting or viewing tickets/chats, and overall response times may be delayed. Phone support remains fully operational for urgent inquiries.
- Updated
We are continuing to investigate this issue.
- Investigating
Our helpdesk provider is currently experiencing issues, and as such customers might encounter errors while submitting or viewing tickets. Responses on customer inquiries may be delayed during this time.