A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2025 - 16:40 UTC
Update
Cloudflare's R2 service is experiencing elevated write latency in the WNAM region. Impacted users will see increased response times on put operations. Stream users may experience longer than usual times for new uploaded videos to be ready to play. Images hosted assets are experiencing higher than usual latency and increased API error responses. Images Transformations, Media Transformations, and Live Broadcasts are unaffected.
Posted Oct 03, 2025 - 16:17 UTC
Investigating
Cloudflare Stream is currently observing longer than usual times for new uploaded videos to be ready to play. Live Streaming, Playback and WebRTC are unaffected. We are working to analyze and mitigate this problem.
Posted Oct 03, 2025 - 15:29 UTC
This incident affected: Cloudflare Sites and Services (Images, R2, Stream).