Cloudflare System Status

Cloudflare Access change delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 17:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2021 - 16:06 UTC
Investigating
Cloudflare is investigating issues with Cloudflare Access where configuration changes experiencing delays.
We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Mar 25, 2021 - 15:51 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Access).