Cloudflare System Status

SSL handshake failures in the China region
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 10, 2021 - 00:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2021 - 00:27 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted Apr 10, 2021 - 00:01 UTC
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 23:31 UTC
Update
We are continuing to investigate this issue.
Posted Apr 09, 2021 - 23:30 UTC
Investigating
Cloudflare is investigating SSL handshake failure errors served out of the China region.

We are working to mitigate this problem. More updates to follow shortly.
Posted Apr 09, 2021 - 23:28 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).