Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 19:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2020 - 18:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 02, 2020 - 17:58 UTC
Investigating
Cloudflare is investigating delays for updates to newly created or edited DNS records. This delay also affects new Argo Tunnel instances.

DNS resolution and established Argo Tunnels are not impacted. More updates to follow shortly.
Posted Jun 02, 2020 - 17:40 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).