Cloudflare System Status

Workers cron trigger issue

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Oct 09, 2025 - 22:52 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted Oct 09, 2025 - 22:42 UTC

Identified

Cloudflare has identified an issue with a subset of cron triggers not being invoked. We are working to mitigate the impact. More updates to follow shortly.
Posted Oct 09, 2025 - 21:12 UTC
This incident affected: Cloudflare Sites and Services (Workers).