Cloudflare System Status

Authoritative DNS lookup problems for some Free plan zones
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 21:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2021 - 15:02 UTC
Identified
A small number of free zones are seeing NXDOMAIN responses
Posted Jun 21, 2021 - 13:54 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Authoritative DNS).