Cloudflare System Status

Certificate Issuance through Let's Encrypt unavailable

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 08, 2026 - 20:58 UTC

Monitoring

We have confirmed recovery and will continue monitoring for improvement.
Posted May 08, 2026 - 20:53 UTC

Investigating

We are aware of an issue affecting certificate issuance through Let's Encrypt. Customers using Universal SSL, Advanced Certificate Manager, or Cloudflare for SaaS may experience delays or failures when issuing or renewing certificates that use Let's Encrypt as the Certificate Authority.
Certificates issued through other CAs (such as Google Trust Services) are not affected. Existing certificates that have already been issued remain valid and are unaffected.
We are actively monitoring Let's Encrypt availability and will issue certificates as soon as service is restored. We will provide updates as more information becomes available.
Posted May 08, 2026 - 19:46 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning, SSL for SaaS Provisioning).