We are continuing to monitor for any further issues.
Posted Jul 30, 2026 - 07:57 UTC
Monitoring
Cloudflare identified that the Network degradation was due to maintenance conducted by fiber providers. The congestion has been alleviated by rerouting traffic. We are currently monitoring the situation and will follow up with more updates shortly.
Posted Jul 30, 2026 - 07:51 UTC
Investigating
Cloudflare is observing possible network congestion in the North America region. Customers may see elevated latency and connectivity issues.
We are working to mitigate impact to Internet users in this region.
Posted Jul 30, 2026 - 05:48 UTC
This incident affected: Cloudflare Sites and Services (Network).