Cloudflare System Status

Unable to Save Page Rules In Cloudflare Dashboard
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 18:17 UTC
Investigating
Customers trying to add or update page rules in the Cloudflare Dashboard may receive errors. We are currently investigating.
Posted Jul 19, 2023 - 18:14 UTC