Cloudflare System Status

Workers, Workers for Platforms, and Pages API Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 00:20 UTC

Monitoring

We have implemented a fix for this issue and are currently monitoring the results.
Posted Aug 19, 2025 - 23:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 19, 2025 - 23:43 UTC

Identified

Cloudflare has identified an issue impacting the Workers, Workers for Platforms, Snippets, and Pages API and is working on a fix. This issue may result in failed deployments. This does not impact edge traffic. Updates to follow.
Posted Aug 19, 2025 - 21:29 UTC

Investigating

Cloudflare is aware of and investigating an issue impacting the Workers API. This may result in failed deployments. This does not impact edge traffic. Updates to follow.
Posted Aug 19, 2025 - 21:19 UTC
This incident affected: Cloudflare Sites and Services (Pages, Snippets, Workers).