Cloudflare System Status

Delays in deploying Cloudflare Workers to a subset of Cloudflare locations
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 20:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2023 - 18:42 UTC
Identified
We have identified the root cause and expect resolution within the hour.
Posted Jul 20, 2023 - 18:09 UTC
Investigating
Cloudflare Workers are currently experiencing delays in deploying to specific locations.
Posted Jul 20, 2023 - 18:04 UTC
This incident affected: North America (Houston, TX, United States - (IAH), Salt Lake City, UT, United States - (SLC)), Europe (Lisbon, Portugal - (LIS)), Asia (Kuala Lumpur, Malaysia - (KUL)), and Cloudflare Sites and Services (Workers).