Cloudflare System Status

Duplicated values in X-Forwarded-For header

Incident Report for Cloudflare

Update

We are continuing to work on a fix for this issue.
Posted Apr 28, 2026 - 20:39 UTC

Update

We are continuing to work on a fix for this issue. A fix is expected to roll out over the next ~11 hours - ETA ~07:00 UTC 29 Apr. 2026.
Posted Apr 28, 2026 - 19:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2026 - 19:00 UTC

Update

We are continuing to investigate this issue.
Posted Apr 28, 2026 - 18:34 UTC

Investigating

Cloudflare is investigating duplicated values in the X-Forwarded-For header. Origins depending on this header may exhibit unexpected behavior.
Posted Apr 28, 2026 - 18:31 UTC
This incident affects: Cloudflare Sites and Services (CDN/Cache, CDN Cache Purge).