The issue has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 15:29 UTC
Investigating
Cloudflare is investigating an increased latency when interacting with Workers Builds via webhooks from git providers. Customers might experience longer wait times on Workers endpoints, particularly when build a project from a git connection. Workers that are already running in production are not affected. More updates to follow shortly.
Posted Apr 15, 2026 - 14:37 UTC
This incident affected: Cloudflare Sites and Services (Workers Builds).