Cloudflare System Status

Issues with Cloudflare's Pay-as-you-Go Plans
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 17, 2024 - 19:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2024 - 16:03 UTC
Investigating
Cloudflare is aware of and investigating an issue with some Pay-as-you-Go plans being downgraded, such as Pro and Business plans.
Posted Mar 17, 2024 - 14:13 UTC
This incident affected: Cloudflare Sites and Services (Billing).