Cloudflare System Status

Cloudflare Registrar Issue
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 02, 2022 - 03:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2022 - 03:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 02, 2022 - 01:59 UTC
Investigating
Cloudflare is aware of Registrar customers unable to register a new domain, and investigating an issue which potentially impacts multiple customers. Further detail will be provided as more information becomes available.
Posted Jun 02, 2022 - 01:51 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Registrar).