Cloudflare System Status

Network Performance Issues in Jakarta

Incident Report for Cloudflare

Update

We are continuing for work on a fix for this issue
Posted Mar 20, 2026 - 15:30 UTC

Update

We are continuing for work on a fix for this issue
Posted Mar 20, 2026 - 13:28 UTC

Update

We are continuing for work on a fix for this issue
Posted Mar 20, 2026 - 12:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2026 - 11:21 UTC

Investigating

Cloudflare is investigating issues with Network Performance for customers in the Jakarta area

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Mar 20, 2026 - 11:09 UTC
This incident affects: Asia (Jakarta, Indonesia - (CGK)) and Cloudflare Sites and Services (Network).