Cloudflare System Status

Workflows instances may get stuck

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 02, 2025 - 22:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 02, 2025 - 22:19 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 02, 2025 - 22:14 UTC

Investigating

Workflows instances may be getting stuck for some limit customers.
Posted May 02, 2025 - 16:46 UTC
This incident affected: Cloudflare Sites and Services (Workflows).