A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 16:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 10, 2026 - 15:56 UTC
Identified
Cloudflare is investigating an increased level of 5xx errors in Philadelphia. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Apr 10, 2026 - 15:55 UTC
This incident affected: North America (Philadelphia, United States - (PHL)).