Cloudflare System Status

Issue solving Challenge Pages

Incident Report for Cloudflare

Resolved

Some visitors may have had issues solving Challenge Pages, unable to complete the challenge successfully
Posted Mar 10, 2026 - 16:45 UTC
This incident affected: Cloudflare Sites and Services (Bot Management, Rules).