Cloudflare System Status

Billing Alert delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 15:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2020 - 14:50 UTC
Update
We are continuing to investigate this issue.
Posted Apr 02, 2020 - 14:38 UTC
Investigating
Cloudflare is investigating an issue where new Usage Based Billing alerts may not be triggered. We are working to resolve the issue. More updates to follow shortly.
Posted Apr 02, 2020 - 13:48 UTC
This incident affected: Cloudflare Sites and Services (Billing).