Cloudflare System Status

SSL Certificate Provisioning Delays

Incident Report for Cloudflare

Resolved

This incident is now resolved.
Posted Mar 15, 2026 - 23:10 UTC

Monitoring

We have identified and implemented a fix for this issue. We are currently monitoring the results.
Posted Mar 15, 2026 - 22:50 UTC

Investigating

Cloudflare is investigating delays in provisioning SSL certificates. New SSL certificate provisioning is taking up to 45 minutes in some cases.

SSL certificates already in production remain unaffected and are operating normally.
Posted Mar 15, 2026 - 22:46 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).