Cloudflare System Status

Cloudflare Vectorize Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 22:47 UTC

Investigating

Cloudflare is investigating issues with the Vectorize service. Customers may receive an "Internal Server Error" (HTTP 500) response when sending requests to a Vectorize index that has been deleted, instead of the expected "Not Found" (HTTP 404) response. Creating, querying, and managing active indexes are not affected, and no other Cloudflare services are impacted. We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jul 04, 2026 - 21:25 UTC
This incident affected: Cloudflare Sites and Services (Vectorize).