Cloudflare System Status

R2 event notifications not delivering to new queues

Incident Report for Cloudflare

Resolved

We’ve identified a bug that causes R2 event notifications to fail to deliver to Queues in very specific circumstances. We’re working on a fix, but the impact is estimated to be very minimal at this time
Posted Aug 17, 2024 - 04:00 UTC

Update

Customers creating their first queue after 8/5 will not receive events from R2
Impacted services - R2 event notifications
Posted Aug 16, 2024 - 18:59 UTC

Investigating

Currently, R2 event notifications only function with existing queues. Newly created queues are not compatible with event notifications.
Posted Aug 16, 2024 - 18:24 UTC
This incident affected: Cloudflare Sites and Services (R2).