Cloudflare System Status

Network Performance Issues in Madrid, Spain

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 08:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 07:33 UTC

Update

Cloudflare is investigating issues with network performance in Madrid, Spain - (MAD). We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Apr 16, 2025 - 07:28 UTC

Investigating

Network Performance Issues in Madrid, Spain (MAD).
Posted Apr 16, 2025 - 07:21 UTC
This incident affected: Europe (Madrid, Spain - (MAD)).