Cloudflare System Status

High R2 request latency in ENAM region

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 21:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 19:14 UTC

Investigating

R2 users with buckets in the ENAM region may be experiencing elevated request latency and lower bandwidth throughput on get and put requests to R2.
Posted Jun 27, 2025 - 18:13 UTC
This incident affected: Cloudflare Sites and Services (R2).