Cloudflare System Status

Network Performance Issues in Chicago (ORD)

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 14:03 UTC

Monitoring

Cloudflare is investigating issues with network performance in Chicago. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Aug 07, 2026 - 13:13 UTC