Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 19:10 UTC
Investigating
Cloudflare is investigating a billing-related issue that may impact our invoice processing system. All other services are operating normally.

We will provide an update once the service returns to normal.
Posted Mar 20, 2024 - 16:14 UTC
This incident affected: Cloudflare Sites and Services (Billing).