Cloudflare System Status

Cloudflare for Teams Dashboard issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 28, 2021 - 11:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 28, 2021 - 11:00 UTC
Investigating
Cloudflare is investigating issues with Cloudflare for Teams Dashboard.

Some users might see problems logging into Cloudflare for Teams Dashboard.
Posted Jul 28, 2021 - 10:19 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Zero Trust Dashboard).