Cloudflare System Status

Some customers may be experiencing issue in viewing support cases on the Cloudflare dashboard

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 12:28 UTC

Update

We are continuing to investigate this issue.
Posted Apr 23, 2025 - 10:48 UTC

Investigating

Some customers may be experiencing issue in viewing support cases on the Cloudflare dashboard. Customer will still be able to create ticket and receive response from support team via email.

In the meanwhile, you may want to try to access the following link directly in the browser to get access to the support cases after login in to the dashboard:

https://www.support.cloudflare.com/s/case/Case/Default
Posted Apr 23, 2025 - 04:27 UTC
This incident affected: Cloudflare Sites and Services (Support Site).