Cloudflare System Status

Workers Assets increased upload failure

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 16:20 UTC

Identified

Cloudflare has identified an issue impacting Workers Assets uploads. Customers may be seeing an increase in Workers Assets upload failures.

This issues does not affect the serving of Workers Assets traffic. We are working to mitigate this problem. More updates to follow shortly.
Posted Apr 10, 2026 - 14:06 UTC
This incident affected: Cloudflare Sites and Services (Workers Assets).