Cloudflare System Status

Cloudflare Pages Availability Issues

Incident Report for Cloudflare

Resolved

This incident has been resolved, users may have seen impact from 11th March 2026 20:10 UTC to 20:55 UTC.
Posted Mar 11, 2026 - 21:01 UTC

Investigating

Cloudflare is investigating availability issues with Cloudflare Pages API, Pages builds and Workers builds.
Customers may be experiencing an increase of errors from the Pages API or seeing build failures in Pages or Workers builds. This does not impact any Pages or Workers traffic.
We are working to mitigate this problem. More updates to follow shortly.
Posted Mar 11, 2026 - 20:57 UTC
This incident affected: Cloudflare Sites and Services (Pages).