Cloudflare System Status

Browser Isolation Services degraded - San Diego, CA, United States
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 04, 2022 - 22:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2022 - 22:23 UTC
Investigating
We are currently investigating disruption for Browser Isolation services in San Diego, CA, United States
Posted Apr 04, 2022 - 21:34 UTC
This incident affected: North America (San Diego, CA, United States - (SAN)).