Cloudflare System Status

Cloudflare: Amazon Web Services incident awareness

Incident Report for Cloudflare

Update

No Cloudflare services are impacted by the ongoing AWS outage. We are continuing to monitor.
Posted Oct 20, 2025 - 17:10 UTC

Monitoring

No Cloudflare services are impacted by the ongoing AWS outage. We are continuing to monitor.
Posted Oct 20, 2025 - 16:14 UTC

Investigating

Cloudflare is closely monitoring the ongoing incident with Amazon Web Services. Currently, no Cloudflare services are impacted by this outage. We will continue to monitor, and will resolve this status page once impact has resolved.
Posted Oct 20, 2025 - 14:55 UTC
This incident affects: Cloudflare Sites and Services (Network).