Cloudflare System Status

Cloudflare Email Routing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 14:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2024 - 14:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 06, 2024 - 11:55 UTC
Investigating
Cloudflare is investigating issues with Email Routing product. Some emails might be temporarily bounced back to the sender.

Impact is restricted to email forwarding functionality and it does not affect any connectivity, security, CDN or Area1 functionality.

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Apr 06, 2024 - 11:28 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).