We are continuing to monitor for any further issues.
Posted Jul 28, 2026 - 18:53 UTC
Monitoring
A subset of customers using Cloudflare Tunnel may have experienced tunnel connectivity issues, including being unable to access private resources and services routed through Cloudflare Tunnel. Customers who are still experiencing issues should restart their cloudflared connectors to restore normal tunnel connectivity. This issue does not affect any other Cloudflare services.
Posted Jul 28, 2026 - 18:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 18:28 UTC
Update
We are continuing to investigate this issue.
Posted Jul 28, 2026 - 17:57 UTC
Investigating
Investigating Cloudflare Tunnel availability issues. Multiple customers reporting tunnels degraded or fully down, including inability to access private resources behind Tunnel. Tunnel engineering team being engaged. No root cause identified yet.
Posted Jul 28, 2026 - 17:56 UTC
This incident affects: Cloudflare Sites and Services (Tunnel).