Cloudflare System Status

Workers Management Dashboard Errors

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 06, 2023 - 17:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2023 - 17:05 UTC

Identified

Workers customers attempting to delete or rename their worker via the Dashboard may encounter errors. Worker code can still be updated using the editor, CLI or API.

We have identified the problem and are working on deploying a fix.
Posted Jul 06, 2023 - 16:00 UTC
This incident affected: Cloudflare Sites and Services (Workers).