Cloudflare System Status

Issue with Invoices
Incident Report for Cloudflare
Resolved
The incident is resolved and invoices are restored. This was purely an invoice display issue and not a security incident. No customer data was comprised.
Posted Apr 27, 2022 - 01:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 26, 2022 - 15:07 UTC
Investigating
Cloudflare is aware that invoices for our self serve customers over the past 24 hours were generated with the wrong template. We are working to address this issue and regenerate the invoices with the right template as soon as possible.
Posted Apr 26, 2022 - 14:57 UTC
This incident affected: Cloudflare Sites and Services (Billing).