Cloudflare System Status

Cloudflare Access delayed audit logs

Incident Report for Cloudflare

Resolved

new audit logs are processing as expected
Posted May 20, 2026 - 21:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 19:47 UTC

Identified

An issue with delay audit logs for Access has been identified. A fix is being prepared to resolve the delayed logs.
Posted May 20, 2026 - 19:40 UTC
This incident affected: Cloudflare Sites and Services (Access).