Cloudflare System Status

Email Delivery Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and E-mail delivery has resumed normal operation.
Posted Oct 28, 2021 - 21:32 UTC
Monitoring
A fix has been implemented to resolve the issue, and we are monitoring the results.
Posted Oct 28, 2021 - 20:33 UTC
Identified
We've identified an issue with our Email Service Provider, and we're working with them to resolve this issue. More updates to follow shortly.
Posted Oct 28, 2021 - 18:38 UTC
Update
Cloudflare is investigating a delay in our ability to send emails. This includes password reset, MFA token emails, Cloudflare Access OTP. We are working to resolve the issue. More updates to follow shortly.
Posted Oct 28, 2021 - 18:23 UTC
Investigating
Cloudflare is investigating a delay in our ability to send emails. This includes password reset, mFA token emails. We are working to resolve the issue. More updates to follow shortly.
Posted Oct 28, 2021 - 18:18 UTC
This incident affected: Cloudflare Sites and Services (Access, Dashboard, Zero Trust Dashboard).