Cloudflare System Status

Dashboard Response Performance

Incident Report for Cloudflare

Resolved

We have identified and applied an effective fix for this issue. This incident is now resolved.
Posted Nov 10, 2025 - 20:07 UTC

Investigating

We are investigating an issue with Cloudflare Dashboard response performance where customers may experience longer load times than normal.
Posted Nov 10, 2025 - 18:03 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).