Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 21:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2020 - 21:22 UTC
Investigating
Cloudflare is experiencing problems processing new payment methods or updating existing ones. All other services are operating normally.

We will provide an update once billing subscription services return to normal.
Posted Apr 30, 2020 - 20:23 UTC
This incident affected: Cloudflare Sites and Services (Billing).