A fix has been implemented, the delay of Page Shield updates had been mitigated to within acceptable threshold. We are continuing to monitor the results.
Posted Apr 06, 2026 - 06:41 UTC
Investigating
Cloudflare is currently investigating an issue where data updates of the Page Shield product are delayed. More updates to follow shortly.
Posted Apr 06, 2026 - 04:52 UTC
This incident affected: Cloudflare Sites and Services (Page Shield).