Cloudflare System Status

Network Performance Issues in Ashburn, VA.

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 13, 2025 - 05:00 UTC

Investigating

Cloudflare has observed issues with network performance in Ashburn, VA on the 13th of May between 04:20 and 04:55 UTC. During this time requests reaching a specific data center in the region could have experienced increased latency and intermittent errors.
Posted May 13, 2025 - 04:15 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)) and Cloudflare Sites and Services (Network).