Cloudflare System Status

DNS Resolution Issues
Incident Report for Cloudflare
Resolved
This issue has been resolved and DNS resolution has returned to normal.
Posted 5 months ago. Jun 30, 2018 - 22:09 UTC
Investigating
Investigating issues with DNS when queried from Google’s recursive service (8.8.8.8).
Posted 5 months ago. Jun 30, 2018 - 18:10 UTC