Cloudflare System Status

Increased Error Rates

Incident Report for Cloudflare

Monitoring

Traffic engineering efforts have successfully mitigated the majority of congestion and packet drops.
Posted Jun 22, 2026 - 16:50 UTC

Update

Traffic engineering efforts have successfully mitigated the majority of congestion and packet drops. Services are largely stable, with only minor residual impact remaining. A small number of intermittent errors may still be observed for services with origins in North America as we work to fully clear the remaining load.
Posted Jun 22, 2026 - 16:30 UTC

Update

Our Engineers are continuing our traffic engineering work to mitigate the impact.
Posted Jun 22, 2026 - 15:40 UTC

Update

Our network teams are continuing active traffic engineering efforts to reroute traffic away from congested links and restore full service stability. We are closely monitoring dashboards and customer reports to confirm recovery and will continue to provide status updates as we manage the remaining load.
Posted Jun 22, 2026 - 15:38 UTC

Update

We are continuing our traffic engineering work to mitigate the impact.
Posted Jun 22, 2026 - 15:12 UTC

Update

We are investigating a fiber cut in Eastern North America. Customers connecting through North America or accessing services in Europe may see increased latencies and timeouts as Cloudflare engineers look to mitigate
Posted Jun 22, 2026 - 14:48 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 22, 2026 - 14:47 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 22, 2026 - 14:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 22, 2026 - 14:37 UTC

Investigating

Cloudflare is investigating increased error rates and latency in multiple services beginning 13:35 UTC.
Posted Jun 22, 2026 - 13:35 UTC
This incident affects: Cloudflare Sites and Services (Analytics, CDN/Cache, Durable Objects).