Cloudflare System Status

Cloudflare Peering Portal Authentication Issue

Incident Report for Cloudflare

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2026 - 13:24 UTC

Identified

Cloudflare is aware of, and investigating an issue which impacts multiple customers/peers who use peering.cloudflare.com. This issue does not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.

Authentication to peering.cloudflare.com is currently affected due to an outage with our third party authentication provider.

Further detail will be provided as more information becomes available.
Posted Feb 27, 2026 - 02:27 UTC